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Import Dynamic Folder Path from Current Excel Workbook File:

1. This formula will show the folder path for the file that the formula lives in:
=TEXTBEFORE(CELL("filename",A1),"[")
Or

=LEFT(CELL("filename",A1),SEARCH("[",CELL("filename",A1))-1)

2. If you name the cell with the above formula “FolderPath”, the resultant folder path can be used to import all
files from the folder regardless of where you move the folder using this Power Query formula in a blank query:

= Folder.Files(Excel.CurrentWorkbook(){[Name="FolderPath"]}[Content]{0}[Column1])

3. In Excel, together these two formulas will always deliver a table of Excel Objects (Excel Tables, Defined Names
and Arrays that have previously been imported into the Power Query Editor) regardless of where the folder is
moved to.

4. These formulas are not available in Power Bl Desktop.

Import Single Object Files: TXT and CSV
1. Text files with the extension “.txt” (Text) are Tab delimited files that are designed to move data from one system
to another.
2. Csv files with the extension “.csv” (Comma Separated Values) are Comma delimited files that are designed to
move data from one system to another.
3. Here are the two connector paths in Power Query:

e Excel:
118 Home Insert Draw Page Layout Formulas Data Review View Ay
% I:E From Text/CSV From Picture v H::[}. | Queries & Connections
& D
7
Get [‘é From Web I:[;) Recent Sources Refresh
Datav B3 From Table/Range D‘ Existing Connections All ~
Get & Transform Data Queries & Connections
e Power Bl Desktop:
File Home Insert Modeling View Help
Gl =1 o EEP
& o (B0 ©® [ B
Get Exce Data SQL Enter Dataverse Recent Transform
datav workbook hubv Server data sources v datav

Clipboard Queries

Common data sources

E

[ﬁ Excel workbook

5‘} Power Bl datasets
[?y Dataflows
(® Dataverse

F SQL Server

i

[% Analysis Services

[hE Text/CSV é Import data from a text or CSV file

[% Web
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Import Single Object Files: PDF

1. Pdffiles are NOT designed to move data from one system to another. However, Power Query can interpret data
from a pdf file with somewhat good results:
2. Here are the two connector paths in Power Query:
e Excel:
File Home Insert Draw Page Layout Formulas _D_aE Review View Automate Devd
[E From Text/CSV E% From Picture v S [ Queries & Connections
% [& From Web [® Recent s, EJ’ U:U
Get @ From Wel ® Recent Sources Refresh 5 .
Data ¥ | B3 From Table/Ranae [P Existing Connections All~ otk il
D From File > [‘E’ From Excel Workbook il
C : Dataverse, Power Bl
I:?j From Database > [:E From Text/CSV
1 & From Azure > <@>] From XML
3 S ]
3 From Power Platform > From JSON 2ath
4
@' From Dnne Seevaces ? St D é :::t:?:ta from a PDF document.
e Power Bl:
File Home Insert Modeling View Help
o
ul T EEp)
@ & BhbE® & P
Get Exce! Data SQL Enter Dataverse Recent Transform
datav workbook hubv Server data sources v datav
Clipboard Queries
Common data sources
0ol
[& Excel workbook
i 5_]\ Power Bl datasets
Eﬁg [?.v Dataflows
@ Dataverse
[‘Ej SQL Server
Pé Analysis Services
[ Text/csv
B web
E OData feed
[__Er Blank query On
EE Power Bl Template Apps
More.. e Connect to data from multiple source:

Import Single Object Files: Picture

1. Picture files are NOT designed to move data from one system to another. However, Excel can interpret data
from a pdf file with varying results:
2. Here is connector the Get & Transform group in the Data tab in the Excel Ribbon (this feature is NOT Power
Query):
e Excel:

Data v % From Table/Range

[Ea Existing Connections All ~

Get & Transform Data

Queries & Connections

File Home raw Page Layout Formulas Data Review View Au
@E I:E] From Text/CSV From Picture v P [T Queries & Connections
[ e
K/ q
Get @ From Web [& Recent Sources Refresh

Page 3 of 19



Import Single Object Files: XML
1. XML files with the extension “.xml|” (eXtensible Markup Language) and are designed to move data from one

system to another.
2. Here are the two connector paths in Power Query:

e Excel:
File Home Insert Draw Page Layout Formulas Data Review View Automate Dev
" E? | [ From Text/csv F& From Picture P [TH Queries & Connections
g
[% From Web [.[:t) Recent Sources e = D:D
Refresh - Bt
\Data | B3 From Table/Ranae [ Existing Connections All ~ 2l
: \ . Connections
From File > [l& From Excel Workbook
Dataverse, Power Bl
|:|[>£] From Database > D From Text/CSV
(S From XML
& From Azure > <®>] From XML . :
[ Import data from an XML file.
e Power Bl
File Home Insert Modeling View Help
Excel Data SQL Enter Dataverse Recent Transform |
data v workbook hubv Server data sources v datav
Clipboard
Common data sources Long list of
il F ost® * Connectors hiddeen
: Ey Excel workbook .
I_—Er Blank query On
EE Power Bl Template Apps
More... @ Connect to data from multiple sources.

Import Single Object Files: JSON
1. Json files with the extension “.json” (JavaScript Object Notation) and are designed to move data from one
system to another.
2. Here are the two connector paths in Power Query:
e Excel:

File Home Insert Draw Page Layout Formulas Data Review View Automate Dew

' E% [} From Text/CSV  EE From Picture P T Queries & Connections
‘|
[% From Web [‘@) Recent Sources Refr:slrl ] D]j
Geography
\Data ) B9 From Table/Ranae [ Existing Connections All ~ Sl
\ .Connections
From File > [E! From Excel Workbook
C Dataverse, Power Bl
I:IF] From Database > I:El From Text/CSV
[

1 & From Azure > From XML

E i e
¢

From JSON
From Power Platform > SON|] From JSON -
Import data from a JSON file,

[P

(W8]
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e Power Bl Desktop:
File Home Insert Modeling View Help
sl ¢ '
EaEhiEe b P
Get Excel Data SQL Enter Dataverse Recent Transform
datav workbook hubv Server data sources v datav
Clipboard
Common data sources Long list of
ol 4s** Connectors hiddeen
[__a Excel workbook 4, *
EEF Blank query On
EE]_ Power Bl Template Apps
More.. @ Connect to data from multiple sources

Import Single Object Files: Excel

1. Excel files can have many objects such as Excel Tables, Worksheets, Defined Names or Dynamic Arrays. When
you import a single Excel file, a Navigator windows allows you to select one or more objects to import, each as a
different query.

2. Here are the two connector paths in Power Query:

e Excel:
File Home Insert Draw Page layout Formulas Data Review View Automate Devg
ﬁ I:E From Text/CSV % From Picture v F @ Queries & Connectjons
553 17
Get Dé From Web D\a Recent Sources Refresh
G hy
\Data ¥ | B3 From Table/Ranae [ Existing Connections All~ cograpny
. N ™ From Excel Workbook
From File Ln From Excel Workbook g
Import data from a Microsoft Excel
¢ workbook.
[ — NI R
e Power Bl Desktop:
File Home Insert Modeling p
b (Lo [ & B
& Lo ol @ o | &
Get Excel Data SQL Enter Dataverse Recent Transform
data v |workbook| hubv Server data sources v data v
Clipboard Data Queries

Import Excel Query or Data Model into Power Bl Desktop (Demonstrated in MECS video #4)
1. When you want to import Queries or Data Model objects (Tables, Relationships and DAX Formulas) from an
Excel file into Power Bl Desktop you DO NOT use the Excel Import Button as shown in previous example. Instead,
you use this connector from the File tab in the Power Bl Desktop Ribbon:

New

Import

Qv

Open report

o

w
"

]

Power Bl template
Save P

Save as ¥ y
B Power Bl visual from file

Get data

Export

[ﬁ] Power Bl visual from AppSource

$ Power Query, Power Pivot, Power View
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Import from Web
1. Power Query has a import connector that allows you to import data from a web site if the web site has been
built and allows data to be exported (not all web sites allow data export).
2. Here are the two connector paths in Power Query:

e Excel:

File Home Insert Draw Page Formulas Data Review View Ay

r [ Queries & Connections
,"'31_ = |

[\% Recent Sources Refresh

Datav B3 From Table/Range DE; Existing Connections All~ |,
Get & Transform Data Queries & Connections
e Power Bl Desktop:
File Home Insert Modeling View Help

| o
G eBhE© L B
Get Excel Data SQL Enter Dataverse Recent Transform
datav workbook hubv Server data sources v datav

Clipboard . Queries

Common data sources
D?l Excel workbook
& Power Bl datasets
ﬁg [?_v Dataflows
: @ Dataverse

D’—'\‘ SQL Server

[ Text/Csv

[% Web é Import data from a web page

Import From: Dataflow or Dataverse
1. Dataflow and Dataverse are Microsoft Power Platforms that allow you to connect to data stored in the platform
and download it into Power Query:
2. Here are the two connector paths in Power Query:
e Excel:

File Home Insert Draw Page Layout Formulas Data Review View Automate Developer

. ﬁ » [E From Text/CSV E& From Picture v Irb_. [[H Queries & Connections
[% From Web [rl}) Recent Sources ~ B U:D E(E
Gt v Refresl, Geography Currer|
Data ¥ ] B From Table/Ranae [P Existing Connections All~ gp
D : i N Queries & Connections Data
rom File
fx  Import From Dataflow, Dataverse, Power Bl
[[?i‘ From Database >
C
1 & From Azure >
2 o
3 From Power Platform > '4‘ ‘ | From Power Bl (Highline Col...)
P

From Dataflows
From Online Services > From Dataflows 5
Import data from a dataflow.
g ire, XML, JSON, Excel, Web
¢ o From Dataverse
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e Power Bl Desktop:

File Home Insert Meodeling View Help
@ hEhbE @ b P
Get Excel Data SQL Enter Dataverse Recent Transform F
datav workbook hubv Server data sources v datav
Clipboard Queries

Common data sources

H fﬁ Excel workbook
g 5‘21 Power Bl datasets

! [ Datafiows ?
é © Dataverse

[‘E SQL Server

Import From: Power Bl
1. The Power Bl data source does not directly allow you to download the data, but instead, you connect to a data
source that is stored and managed in one location in the Microsoft Power Platform (powerbi.com as discussed in
MECS video #4) and build reports and visuals through a connection to that online data source. In Excel you can
build PivotTable and PivotCharts from the data source. In power Bl Desktop, you can build report pages with
visuals from the data source.
2. Here are the two connector paths in Power Query:

e Excel:

File Home Insert Draw Page layout Formulas Data Review View Automate Developer

( [k@ From Text/CSV & From Picture v ’» [TH Queries & Connections
W q
[® From Web [® Recent Sources | f
get Refresh Geography Currei
\Data v | B3 From Table/Ranae [T Existing Connections All~ areeTy
Queries & Connections Data
From File >
C fx  Import From Dataflow, Dataverse, Power Bl

[‘?}] From Database >

& From Azure >

From Power Platform > ] ‘ s b
- J— frombower BlitBghlae Col-) Create a PivotTable connected to a

Power Bl dataset

From Power Bl (Highline College)

| S T NS Ty

|—[j From Online Services > [_%_9 From Dataflows

e Power Bl Desktop:

File Home Insert Modeling View Help
58 (o | B i [A]
< = A
ELhIEDhE® b P i LA
Get Exce Data SQL Enter Dataverse Recent Transform New  Text
datav workbook hubv Server data sources v datav visual box
Clipboard Queries nzel

Common data sources

ra Excel workbook

9 \‘_EI% Power Bl datasets Create a live connection to dataset:
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Import From SQL Database

1.

4.

6.

Most data in the world is stored in an SQL Database. SQL means “Structured Query Language” This computer
language can be used to build and query databases.

When the SQL computer language is used to query a database, the methods used to extract and transform the
data from that database are usually very efficient.

Usually, the equivalent SQL query is much more efficient than an equivalent M Code query. Because of this fact,
when using Power Query to connect to and query an SQL database, a process called “Query Folding” takes place
which sends the M Code generated query back to the source SQL database to be executed in the more efficient
SQL environment.

To determine if a query step is sent back to the SQL database, right-click the query step and if you see “View
Native Query” in the dropdown and it is not grayed-out, you know the step is being sent back (see picture
below). If you click “View Native Query” from the dropdown, you can see the SQL code being sent back (see
picture below).

4 APPLIED STEPS

Source

Navigation

~ D ative Que
GetColoradoRecords Nat Que
GetCost select [_].[Standard Cost] * [_].[Quantity] as [COGS],
Cal - S [_].[Product2] as [Product]
CalculateCOGS o
x Keepp_,..a..»r‘rv:c (
Edit Settings select [$Outer].[Product2],

[$Outer].[Quantity],
E]j Rename [$Inner].[Standard Cost]
RS from
X Delete (
select [_].[Date] as [Date],
Delete Until End [_].[Website] as [Website],
[_].[Product] as [Product2],
Insert Step After [_].[Quantity] as [Quantity],
[_].[RevenueDiscount] as [RevenueDiscount],
[]
1
d

.[NetStandardCost] as [NetStandardCost]
A Move before Let ardcost] ‘ = e

from [dbo].[fTransactions] as [_]
where [_].[Website] = 'coloradoboomerangs.com' and [_].[Website] is not null
) as [$0uter]
left outer join [dbo].[dProduct] as [$Inner] on ([$Outer].[Product2] = [$Inner].[Product])

’ ) as []
qa View Native Query

Properties...

Extract Previous

The rule in Power Query is to put as many steps as possible that can be sent back to the SQL database at the top
of the Applied Steps list, because once you have a step that can’t be sent back to the SQL database, then all
remaining steps in the Applied Steps list will not be sent back to the SQL database. For example, if you apply
Data Types, this step cannot be sent back for query folding, so this step should be kept until the very end of the
query. For a list of steps that can and cannot be used in query folding, check out this Microsoft article with full
details about query folding: https://learn.microsoft.com/en-us/power-query/power-query-folding
Here are the two connector paths in Power Query:

e Excel:

File Home Insert Draw Page layout Formulas Data Review View Al

ﬁ . [E From Text/CSV E‘:@q From Picture v [_[_TA_ |E Queries & Connections
Get [% From Web [t(;; Recent Sources Refr;;a
\Data | &5 From Table/Ranae [ Existing Connections All~
Queries & Connections
D From File >
yi

f
[?j[ From Database 9 I:?:} From SQL Server Database
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e Power Bl Desktop:

File Home Insert Meodeling View Help

[=
Get £Xce U

SQL Enter Dataverse Recent
data v workbook Server data sources v

Data

Import From Folder (All Files Have One Object): Text, CSV or Excel file

1.

When you use this feature you point Power Query to a folder and it can list all files and folders with attributes
for the files and folders.
Often this feature is used to collect tables of data from files and then append the tables into a single table. The
most important tip when appending tables from a folder, is that you must make sure that each table being
appended has the same structure, such as same number of fields, same data types for each field and same field
names for each field.
Here are the two connector paths in Power Query:

e Excel:

File Home Insert Draw Pagelayout Formulas Data Review View Automate Devw

' % [E From Text/CSV E@t‘} From Picture v F |E Queries & Connections [
O Boopetie || W
R

Get [Fé From Web [% Recent Sources Refresh o

\Data v | B3 From Table/Ranae M Existing Connections All~ grapty
. 1 . Connections
From File > ﬂ:‘! From Excel Workbook
; L

& From Database > [‘% From Text/CSV

1
> Y
2 From Azure [<&>] From XML br Bl Desktop Power Query
3
1 s| =
From Power Platform 5on)  From JSON namic file path
5 der Path
6 D From OnlineServices > ,:m From PDF Without Formula.Firewall Errd
7 == — shle data
g D D From Folder
q do ] ko Folder Import metadata and links about
files in a folder.
g¢ [ )

e Power Bl Desktop:

o Go to Home tab, Data group, Get Data dropdown, More, Folder.

The M Code functions Folder.Contents and Folder.File are described in the next section.

When importing Tab or Comma Delimited files you can use the Csv.Documnet M Code function as described 2
sections ahead.

When importing Excel files, you can use the Excel.Workbook M Code function as described 3 sections ahead.

Folder.Contents and Folder.File M Code functrions

e Folder.Contents = This M Code functions imports all content directly inside folder, both files and folders.
This function does not retrieve any files from within sub-folders.

e Folder.File = This M Code functions imports all files directly inside a folder and from within all
subfolders.
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Csv.Document function
e This function can extract a table of data from a CSV file.
e Arguments:
e (Csv.Document(File Source, Columns, Delimiter, ExtraValues)
o File Source = file such as “.csv” or “.txt”.
o Columns = can be null, the number of columns, a list of column names, a table type, or an options
record. Default = all columns. Type table option allows you to add Data Types, like:

X v fx = Csv.Document(Source,type table [#"Fruit"=text,#"Units"=Int64.Type,#"Date"=date])
. AR Fruit ~ | 123 Units v Date v
1 Apple 43 2/2/2023
2 Orange 69 2/3/2023
o]

o Delimiter = can be a single character, a list of characters (multiple delimiters), a list of fixed widths, or
the value ""

, which indicates rows should be split by consecutive whitespace characters. Default =",
(comma).
o ExtraValues =
i. ExtraValues.List = 0 = If the splitter function returns more columns than the table expects, they
should be collected into a list.
ii. ExtraValues.Error = 1 = If the splitter function returns more columns than the table expects, an
error should be raised. This is the default.
iii. ExtraValues.lgnore = 2 = If the splitter function returns more columns than the table expects,
they should be ignored.

iv. Pictures:
fx = Csv.Document(Source, 2, ",", ExtraValues.List)
or
= Csv.Document(Source, 2, ",", 9)
7'( = Csv.Document(Source, 3, ",")
. A% Column1 ~| [] coumn2 ar
1 Apple List
2 Orange List
. A% Columnl ~ | AB- Column2 ~ | AB- Column3 List
1 Apple 43 2/2/2023 43
2 Orange 69 2/3/2023 2/2/2023
7x = Csv.Document(Source, 2, ",", ExtraValues.Error) 71 = Csv.Document(Source, 2, ",", ExtraValues.Ignore)
or or

= Csv.Document(Source, 2, ",", 1) = Csv.Document(Source, 2, ",", 2)

. ABC Columnl . ABC Column2 . & ABC Columnl > ABC Column2 i
I I I I I I I I I I I I T IR IIIIIIIIIIIIIIIIIIIIIIII I

1 Error Error 1 Apple 43

2 Error Error 2 Orange 69
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o Forthe Csv.Document function, if a record is specified for columns (and delimiter, extraValues, and
encoding are null), the following record fields may be provided: [Delimiter, Columns, Encoding, CsvStyle,
QuoteStyle]

i. Example of a record in second argument:

Csv.Document([Content],
[Delimiter="#(tab)", Columns=2, Encoding=1252, CsvStyle=CsvStyle.QuoteAfterDelimiter, QuoteStyle=QuoteStyle.None])

ii. Settings inside Record:

1. Delimiter = Set delimiter in record like: Delimiter="#(tab)” for tab or Delimiter=",” for
comma.

2. Columns = Set columns in record like: Columns=3 for three fields in resulting table. If
you omit this setting, the Csv.Documnet function will automatically take the number of
columns as determined by the delimiter. If you use the user interface (CSV/Text button),
the number of columns will be hard coded in, such as Columns=3 for three columns. If
the number of columns changes later, this setting will not automatically update (in this
case it may be better to not include the setting in the record.

3. Encoding = type of file encoding =

e TextEncoding.Utf16 = 1200 = UTF16 little endian binary form.

e TextEncoding.Unicode = 1200 = UTF16 little endian binary form.

e TextEncoding.BigEndianUnicode = 1201 = UTF16 big endian binary form.

e TextEncoding.Windows = 1252 = Windows binary form.

e TextEncoding.Ascii = 20127 = ASCII binary form.

e TextEncoding.Utf8 = 65001 = UTF8 binary form. This is the default.

4. CsvStyle = Specifies how quotes are handled =

e CsvStyle.QuoteAfterDelimiter = 0 = Quotes in a field are only significant

immediately following the delimiter. This is the default.

_fr = Csv.Document(File.Contents("F:\CsvStyle.csv"),
[CsvStyle = CsvStyle.QuoteAfterDelimiter])

| *CsvStyle.csv - Notepad

File Edit Format View . A% Columni ~ | AB. Column2 -

] 43, "Rad" 1 43 Rad"
Source File: Becomes:

e CsvStyle.QuoteAlways = 1 = Quotes in a field are always significant, regardless
of where they appear.

Pat v 71 = Csv.Document(File.Contents("F:\CsvStyle.csv"),
[CsvStyle = CsvStyle.QuoteAlways],*

| *CsvStyle.csv - Notepad

File Edit Format View . A% Columnl ~ | AB. Column2 -

) 43, "Rad" 1 43 Rad
Source File: Becomes:
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iii. Settings inside Record (continued):
1. QuoteStyle = Specifies how quoted line breaks are handled =
e QuoteStyle.None =0 = Ignore quoted line breaks. This is the default.
e QuoteStyle.Csv =1 = Apply all line breaks.

e Examples:

QuoteStyle=QuoteStyle.None or 0:
"Quad Quad
—_—l 1 Row

Carlota" Carlota
QuoteStyle=QuoteStyle.Csv or 1:
"Quad uad

, | — 2 2 Rows
Carlota Carlota

Import Excel Files with Multiple Objects From Folder
1. When you use the From Folder feature on Excel files with multiple objects, you must use the Excel.Workbook
function to extract all the objects from the Excel file and then filter to get just the objects that you want.
2. The following section gives you information about the Excel. Workbook function.

Excel.Workbook function

e Excel.Workbook function will extract all the objects from a specified external Excel workbook file and deliver a
table to the Power Query Editor that lists all the objects and object attributes so that you can chose which
objects to import.

e Although the official Microsoft web site does not define what sort of objects this function will extract, and
instead just states that the function extracts “content”, it is important to know what type of objects the function
will extract because some of the objects can cause unexpected results. Some of the possible Excel objects that
the function extracts are listed here:

o Excel worksheets with all content on the sheet.

Excel Tables.

Defined Names that are manually created.

Defined Name that is automatically created when you define a print range.

Defined Name that is automatically created when you use the Auto Filter feature.

o The Defined Names, Criteria and Extract, that are created when you use the Advanced Filter feature.

e The three arguments in the function are:

o Excel.Workbook(Excel File, Promote Headers, Delay Data Types)

o Excel File = Excel File as binary

o Promote Headers = true or false to indicate if headers (fields) in final table should be promoted from
text in the first row to headers (fields). Default = false.

o Delay Data Types = true or false to indicate if Data Types should be applied. Default = false. Note: using
false and letting the Excel.Workbook() set the Data Types has two important points to think about: 1) It
may not always get the right Data Type (for example, it may interpret a whole number as a Decimal),
and 2) the query may run slower than setting the argument to true and then added an extra query step
to change Data Types.

O O O O
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Excel.Workbook(Excel file, Promote Headers, Delay Data Types

1st argument = 2nd argument = true / false = 3rd argument = true / false =
Excel File Final table has field names Final table has data types applied

Import All Excel Tables From Inside Current Workbook

e Toimport all the Excel Tables from within the current workbook, you can use the Excel.CurrentWorkbook M
Code function. Information about this function is presented in the next section.

Excel.CurrentWorkbook()

e Excel.CurrentWorkbook() is an argumnetless function that rreturns the contents of the current Excel workbook.

o It returns Excel Tables, Named Ranges (including those automatic names created when you use a print
range, filter or advanced filter), and dynamic arrays.

o Unlike Excel.Workbook, it does not return sheets.

o When you use the Excel.CurrentWorkbook() function If you load a query result to the worksheet, you
must filter out the query name to avoid recursion, which is the query result being imported to itself
(because the query result in an Excel Table).

o You do not have the recursion problem if you load the data to a PivotTable Cache or the Data Model.

Import All Excel Worksheets From Inside Current Workbook
Example not in this video, but here is video link):
https://www.youtube.com/watch?v=KfuYxBDBkAo&Ic=Ugwl4Ney9Q xVcmla6l4AaABAg
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Query 19 (Solution for Blank Rows & Columns and Dynamic Field Names an Data Types)

e This is the Control Sheet in the Excel file named “13-M365-BlankRowsColsFinished.xlsx”:

W N O BW N

27

29
30
31
32
33

24

A B C D E

L]
DynamicFolderPath:

Date date
F:\M 365 Excel - Busn 218\13-M365ExcelClass-Files\19RemoveBlankRowColumnsTextFiles Sales decimal

Product  text
NameOfFolderWithFiles: City text

19RemoveBlankRowColumnsTextFiles

Goals:
Use From Folder to Get Excel files with a Single Sheet
Remove Blank Rows & Columns from all tables
Combine all tables into one table
Dynamically Assign correct Field Names & Data Types
Steps:
1 Import Dynamic Folder Path and access "Blank" Folder (Start to final table)
2 Import CFN Excel Table as a Source for other queries
3 Extract List of Correct Field Names from CFN
4 Create Custom Column let statement to Remove Blank Rows & Columns & Fix Field Names
5 Finish Append Query (final table)
6 Create M Code Data Type Lookup Table (so Data Types & Field Names can be dynamic)
7 Create List of Lists of Correct Field Names and Data Types from CFN
8 Add step to final table that adds Dynamic Data Types & Field Names
9 Test solution on different folders of data (big and small)

10 Implement solution in Power Bl Desktop

Folders:

19RemoveBlankRowColumnsTextFiles

19-2-BigData Date date
Product text
SalesRep text
Sales decimal
City text

Big Data Fields:

cfN Bl typeNameld

TypeName
decimal
Currency.Type
Int64.Type
Percentage.Type
datetime

date

time
datetimezone
duration

text

logical

binary

any
nullablenumber
anynonnull
none

Small Table Field Names:

Date date
Sales decimal
Product text
City text

H

B4 patatypes -

type number
Currency.Type
Int64.Type
Percentage.Type
type datetime
type date

type time

type datetimezone
type duration

type text

type logical

type binary

type any

type nullable number
type anynonnull
type none

{{"decimal",type]
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e Goals and Steps of Project:

Goals:

Combine all tables into one table

Steps:

5 Finish Append Query (final table)

Use From Folder to Get Excel files with a Single Sheet
Remove Blank Rows & Columns from all tables

Dynamically Assign correct Field Names & Data Types

1 Import Dynamic Folder Path and access "Blank" Folder (Start to final table)
2 Import CFN Excel Table as a Source for other queries
3 Extract List of Correct Field Names from CFN

4 Create Custom Column let statement to Remove Blank Rows & Columns & Fix Field Names

6 Create M Code Data Type Lookup Table (so Data Types & Field Names can be dynamic)
7 Create List of Lists of Correct Field Names and Data Types from CFN
8 Add step to final table that adds Dynamic Data Types & Field Names
9 Test solution on different folders of data (big and small)
10 Implement solution in Power Bl Desktop

. . . . n n .
e Step 1in Project: Import Dynamic Folder Path and access "Blank" Folder (Start to final table)
Queries [5] < fr = Folder.Files(Excel.Currentkorkbook(){[Name="FolderPath"]}[Content]{@}[Columnl]) v QU\E""}“‘ Settinas
FH FactTable >
E. E] Content Las ABC Name i ABC Extension - Er'ly Date accessed - Er'!; Date modified
A CFNSource = - 4 PROPERTIES
D et 1 Binary Burien.xlsx xsx 2/25/23 9:35:46 AM 2/15/239
ame
& 2 Binary Qakland xlsx xlsx 2/25/23 9:35:46 AM 2/15/23 9 -
[ LookupTableTypes > FactTacle
Y 3 Binary Tacoma.xlsx Xlsx 2/25/23 9:35:46 AM 2/15/23 9
D ListListFieldNamesDataTypes

All Properties

4 APPLIED STEPS

Source
FixTables
CombineTables
AddDataTypes

e Step 2 in Project: Import CFN Excel Table as a Source for other queries

Queries [5] < ﬁ = Table.TransformColumnTypes(Source,{{"CFN", type text}, {"TypeName", type text}}) v Qué"‘w‘ Settinas
E3 FactTable T =
. A% o ~| AB. TypeName ~
[ CFNSource 4 PROPERTIES
1 Date date
B ustcen - Name
2 Sales decimal s
[ LookupTableTypes e R CHiboines
[ ListlistFieldNamesDataTypes 4 cy text

All Properties

4 APPLIED STEPS

Source
X AddDataTypes
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e Step 3 in Project: Extract List of Correct Field Names from CFN

Queries I3 < ] ;
e X = CFNSource[CFN] v R - S S
uery Settings
B FactTable Query J
List
E CFNSource Pl 4 PROPERTIES
[ Lstcen 5 Name
B LookupTableTypes 3 Product ListCFN
D ListListFieldNamesDataTypes 4 City All Properties
4 APPLIED STEPS
Source

Step 4 in Project: Create Custom Column let statement to Remove Blank Rows & Columns & Fix Field Names

FactTable

let

Source =

Folder.Files(Excel.CurrentlWorkbook(){[Mame="FolderPath"]}[Content]{2}[Columnl]),

let

FixTables = Table.AddColumn(Source, "FixTables", each

> s

OneExcelSheet = Excel.Workbook([Content]){2}[Data],

RemoveBlankRowl = Table.SelectRows(OneExcelSheet, each not List.IsEmpty(List.RemoveMatchingItems(Record.FieldValues(_), {"", null}))),
Transposedl = Table.Transpose(RemoveBlankRowl),

RemoveBlankRow2 = Table.SelectRows(Transposedl, each not List.IsEmpty(List.RemoveMatchingItems(Record.FieldValues(_), {"", null}))),
Transposed2 = Table.Transpose(RemoveBlankRow2),

RemoveTopRow = Table.Skip(Transposed2),

FileName = [Name],

GetLineName = Table.AddColumn(RemoveTopRow, "GetlLineName", each Text.BeforeDelimiter(FileName, "

."), type text),
NameFields = Table.RenameColumns(GetLineName,List.Zip({Table.Columniames(GetLineName),List{FN}))

NameFields

)s

CombineTables = Table.Combine(FixTables[FixTables]),
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e Step 5in Project: Finish Append Query (final table)
NameFields = Table.RenameColumns(GetlLineName,List.Zip({Table.Columnhames(GetLineName),List(FN}))
in
NameFields
)s
| CombineTables = Table.Combine(FixTables[FixTables]),
AddDztaTypes = Table.TransformColumnTypes(CombineTables,ListListFieldNamesDataTypes)
in
AddDataTypes
°

Step 6 in Project: Create M Code Data Type Lookup Table (so Data Types & Field Names can be dynamic)

LookupTableTypes

//LookupTableTypes

let

Source = Table.FromRows({{"decimal”,type number},{"Currency.Type",Currency.Type},{"Int64.Type",Int64.Type},{"Percentage.Type",

Percentage.Type}, {"datetime”,type datetime},{"date”,type date},{"time",type time},{"datetimezone”,type datetimezone}, {"duration”,
type duration},{"text",type text},{"logical”,type logical},{"binary”,type binary},{"any”,type any},{"nullablenumber”,type
nullable number},{"anynonnull”,type anynonnull},{"none",type none}},{"TypeName","DataTypes"}),

BufferTable = Table.Buffer(Source)

in
BufferTable
e Step 7 in Project: Create List of Lists of Correct Field Names and Data Types from CFN
Queries 5] < fx 7= Table.ToRows (RemoveKeyField) v AR GatE
- : ¢ Query Settings
B FactTable - Query Setting
List
E CFNSource 7 I 4 PROPERTIES
D ListCFN 2 st Name
E LookupTableTypes 3 List ListListFieldNamesDataTypes
D ListlistFieldNamesDataTypes 4 Lst

All Properties

~

APPLIED STEPS

Source
LookupTypes
CreateTypeField
RemoveKeyField

X ListListNamesTypes
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e Step 8in Project: Add step to final table that adds Dynamic Data Types & Field Names
NameFields = Table.RenameClolumns(GetLineName,List.Zip({Table.ColumnNames(GetLineName),ListCFN}))
in
NameFields
)s
CombineTables = Table.Combine(FixTables[FixTables]),
I AddDataTypes = Table.TransformColumnTypes(CombineTables,ListListFieldNamesDataTypes)
in
AddDataTypes
°

Step 9 in Project: Test solution on different folders of data (big and small)

W 00~ O U AW N e

BN oo

© o o

W oW wwmn NN NN NN NN
W N = O WwWoLNOUL s WN-=O

DynamicFolderPath:

F:\M 365 Excel - Busn 218\13-M365ExcelClass-Files\19RemoveBlankRowColumnsTextFiles

NameOfFolderWithFiles:
19RemoveBlankRowColumnsTextFiles

Goals:
Use From Folder to Get Excel files with a
Remove Blank Rows & Columns from all tabl
Combine all tables into one table
Dynamically Assign correct Field Names & Data Typ
Steps:

1 Import Dynamic Folder Path and access "Blank" Folder (Sta

2 Import CFN Excel Table as a Source for other queries

3 Extract List of Correct Field Names from CFN

4 Create Custom Column let statement to Remove Blank Rows & Colu

5 Finish Append Query (final table)

6 Create M Code Data Type Lookup Table (so Data Types & Field Names can be

7 Create List of Lists of Correct Field Names and Data Types from CFN

8 Add step to final table that adds Dynamic Data Types & Field Names

9 Test solution on different folders of data (big and small)

10 Implement solution in Power Bl Desktop

Folders:
19RemoveBlankRowColumnsTextFiles
19-2-BigData

C D E F G
TypeName
Date date decimal
Sales decimal Currency.Type
Product  text Int64.Type
City text 4 Percentage.Type
datetime
¢ date
time
datetimezone
duration
text
logical
binary
any
nullablenumber
anynonnull
none
Big Data Fields: Small Table Field Names:
Date date Date date
Product text Sales decimal
SalesRep text Product text
Sales decimal City text
City text

Page 18 of 19




File

Step 10 in Project: Implement solution in Power Bl Desktop. Below is a picture of the Power Query Editor in the Start file named “13-M365-

BlankRowsColsStart.pbix”.

O Search

13-M365-BlankRowsColsStart - Power Bl Desktop
Home Insert Modeling View Help
9 [(BHE [ B [2
(& Lo | [‘?- @ [ B B
Excel Data Enter Dataverse Recent Transform Refresh
datav workbook hubv Serve.' data sources v datav
Clipboard Data Queries

e

Home

| 13-M365-BlankRowsColsStart - Power Query Editor
Transform

I

New Recent
Source ¥ Sources ~

Add Column Tools

| &
% [} Advanced Editor

Refresh
Preview ~ =] Manage ~

View Help

=X

m P
Close &
Apply ¥
Close

lj« LD Properties

Data source
settings

Enter
Data

Manage
Parameters v

New Query Data Sourc...  Parameters Query

Jx

(5] DataTypelookupTable B, f‘;g DataTypes

= Table.FromRows({{"decimal",type number},{"Currency

i [A] 07

Text More
box visualsv

nsert

New

visual

|_ov A

Bd

Manage Reduce
Columns ¥ Rows~

Sort

B CFN 1
B fSales

decimal
Currency.Type
Int64.Type
Percentage.Type
datetime

date

time
datetimezone
duration

text

logical

binary

any

14 nuliablenumber

2 COLUMNS, 16 ROWS Column profiling based on top 1000 rows
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Sensitivity
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DataTyp
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